NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2014-9489 — gollum

HIGHFix: gollum/grit_adapter@4520d97

CVE-2014-9489 is a high-severity (CVSS 8.8) CWE-284 vulnerability in gollum. A fix is available for gollum — see the affected versions and patch details below.

gollum and gollum-lib allow remote authenticated users to execute arbitrary code

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk+0.65%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.67%1.60%2.53%3.46%1.2%2.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎gollum💎gollum-lib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string master is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsgollumall versions3.1.1bundle update gollum --conservative
💎RubyGemsgollum-liball versions4.0.1bundle update gollum-lib --conservative

Affected Products

3 products · 3 configurations
Application
gollumgollum_project
≤ 3.1.0
range
Application
gollum-libgollum_project
≤ 4.0.0
range
Application
grit adaptergollum_project
≤ 0.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gollum, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update gollum to 3.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-9489 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string `master` is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the `-O` or `--open-files-in-pager` flags.
O3 Security · Impact-Aware SCA

Is CVE-2014-9489 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2014-9489: gollum RCE — Fixed in 3.1.1