NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-25288 — mantisbt

MEDIUMFix: mantisbt/mantisbt@221cf32

CVE-2020-25288 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in mantisbt/mantisbt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.

MantisBT XXS where a Custom Field with a crafted Regular Expression property is used

Also known asGHSA-qgrr-f26j-87vf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.24%0.83%1.41%1.99%0.7%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘mantisbt/mantisbt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in MantisBT before 2.24.3. When editing an Issue in a Project where a Custom Field with a crafted Regular Expression property is used, improper escaping of the corresponding form input's pattern attribute allows HTML injection and, if CSP settings permit, execution of arbitrary JavaScript.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmantisbt/mantisbt≥ 2.23.0&&< 2.24.32.24.3composer require mantisbt/mantisbt:^2.24.3

Affected Products

1 product · 1 configurations
Application
mantisbtmantisbt
< 2.24.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mantisbt/mantisbt to 2.24.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25288 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in MantisBT before 2.24.3. When editing an Issue in a Project where a Custom Field with a crafted Regular Expression property is used, improper escaping of the corresponding form input's pattern attribute allows HTML injection and, if CSP settings permit, execution of arbitrary JavaScript.
O3 Security · Impact-Aware SCA

Is CVE-2020-25288 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-25288: mantisbt — Fixed in 2.24.3