NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2020-24855 — @easy-team/easywebpack-cli

MEDIUMFix: easy-team/easywebpack-cli@eb3f546

CVE-2020-24855 is a medium-severity (CVSS 5.3) Path Traversal vulnerability in @easy-team/easywebpack-cli. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @easy-team/easywebpack-cli — see the affected versions and patch details below.

easywebpack-cli Path Traversal vulnerability

Also known asGHSA-252h-2cmq-pmr6
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-24855.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.05%1.57%0.4%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@easy-team/easywebpack-clinpm
103downloads / week

Description

Directory Traversal vulnerability in easywebpack-cli before 4.5.2 allows attackers to obtain sensitive information via crafted GET request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@easy-team/easywebpack-cliall versions4.5.2npm install @easy-team/easywebpack-cli@4.5.2

Affected Products

1 product · 1 configurations
Application
easywebpack-clieasyjs
< 4.5.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @easy-team/easywebpack-cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @easy-team/easywebpack-cli to 4.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-24855 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory Traversal vulnerability in easywebpack-cli before 4.5.2 allows attackers to obtain sensitive information via crafted GET request.
O3 Security · Impact-Aware SCA

Is CVE-2020-24855 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-24855: Path Traversal — Fixed in 4.5.2