NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2020-24710 — gophish

MEDIUMFix: gophish/gophish@e3352f4

CVE-2020-24710 is a medium-severity (CVSS 5.3) Server-Side Request Forgery (SSRF) vulnerability in github.com/gophish/gophish. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/gophish/gophish — see the affected versions and patch details below.

Gophish vulnerable to Server-Side Request Forgery

Also known asGHSA-9c9w-9pq7-f35hGO-2023-1982
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.23%1.84%0.5%1.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/gophish/gophish

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Gophish before 0.11.0 allows SSRF attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/gophish/gophishall versions0.11.0go get github.com/gophish/gophish@v0.11.0

Affected Products

1 product · 1 configurations
Application
gophishgetgophish
< 0.11.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gophish/gophish, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/gophish/gophish to 0.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-24710 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

Gophish before 0.11.0 allows SSRF attacks.
O3 Security · Impact-Aware SCA

Is CVE-2020-24710 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-24710: gophish SSRF — Fixed in 0.11.0