NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2019-16146 — gophish

MEDIUMFix: gophish/gophish#1547

CVE-2019-16146 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in github.com/gophish/gophish. A fix is available for github.com/gophish/gophish — see the affected versions and patch details below.

Gophish XSS Vulnerability

Also known asGHSA-9h9f-9q8g-6764GO-2023-1936
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/gophish/gophish

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Gophish through 0.8.0 allows XSS via a username.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/gophish/gophishall versions0.9.0go get github.com/gophish/gophish@v0.9.0

Affected Products

1 product · 1 configurations
Application
gophishgetgophish
≤ 0.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gophish/gophish, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/gophish/gophish to 0.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16146 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Gophish through 0.8.0 allows XSS via a username.
O3 Security · Impact-Aware SCA

Is CVE-2019-16146 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2019-16146: gophish XSS — Fixed in 0.9.0