NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2308 — kubernetes

MEDIUMFix: jenkinsci/kubernetes-plugin@7aac209

CVE-2020-2308 is a medium-severity (CVSS 4.3) vulnerability in org.csanchez.jenkins.plugins:kubernetes. A fix is available for org.csanchez.jenkins.plugins:kubernetes — see the affected versions and patch details below.

Missing Authorization in Jenkins Kubernetes Plugin

Also known asGHSA-rr6j-37cv-c7x7
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk-0.14%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.55%1.11%1.66%0.1%1.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.csanchez.jenkins.plugins:kubernetes☕org.csanchez.jenkins.plugins:kubernetes☕org.csanchez.jenkins.plugins:kubernetes☕org.csanchez.jenkins.plugins:kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Kubernetes Plugin prior to 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 does not perform a permission check in an HTTP endpoint.

This allows attackers with Overall/Read permission to list global pod template names.

Kubernetes Plugin 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 requires Overall/Administer permission to list global pod template names.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.csanchez.jenkins.plugins:kubernetes≥ 1.27.1&&< 1.27.41.27.4org.csanchez.jenkins.plugins:kubernetes:1.27.4
☕Mavenorg.csanchez.jenkins.plugins:kubernetes≥ 1.26.0&&< 1.26.51.26.5org.csanchez.jenkins.plugins:kubernetes:1.26.5
☕Mavenorg.csanchez.jenkins.plugins:kubernetes≥ 1.22.0&&< 1.25.4.11.25.4.1org.csanchez.jenkins.plugins:kubernetes:1.25.4.1
☕Mavenorg.csanchez.jenkins.plugins:kubernetesall versions1.21.6org.csanchez.jenkins.plugins:kubernetes:1.21.6

Affected Products

1 product · 1 configurations
Application
kubernetesjenkins
≤ 1.27.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.csanchez.jenkins.plugins:kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.csanchez.jenkins.plugins:kubernetes to 1.27.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2308 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1612862361-1.el7RHSA-2021:0637
Red Hat OpenShift Container Platform 4.5jenkins-2-plugins-0:4.5.1610108899-1.el7RHSA-2021:0034
Red Hat OpenShift Container Platform 4.6jenkins-2-plugins-0:4.6.1608634578-1.el7RHSA-2021:0038

Frequently Asked Questions

Jenkins Kubernetes Plugin prior to 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to list global pod template names. Kubernetes Plugin 1.27.4, 1.26.5, 1.25.4.1, and 1.21.6 requires Overall/Administer permission to list global pod template names.
O3 Security · Impact-Aware SCA

Is CVE-2020-2308 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2308: kubernetes — Fixed in 1.27.4