NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1000187 — kubernetes

MEDIUMFix: jenkinsci/kubernetes-plugin@43a1d15

CVE-2018-1000187 is a medium-severity (CVSS 6.5) Information Exposure vulnerability in org.csanchez.jenkins.plugins:kubernetes. A fix is available for org.csanchez.jenkins.plugins:kubernetes — see the affected versions and patch details below.

Exposure of Sensitive Information in Jenkins Kubernetes Plugin

Also known asGHSA-v67x-gpg7-mwv3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk-0.14%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.59%1.18%1.77%0.3%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.csanchez.jenkins.plugins:kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.7.0 and older in ContainerExecDecorator.java that results in sensitive variables such as passwords being written to logs.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.csanchez.jenkins.plugins:kubernetesall versions1.7.1org.csanchez.jenkins.plugins:kubernetes:1.7.1

Affected Products

1 product · 1 configurations
Application
kubernetesjenkins
≤ 1.7.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.csanchez.jenkins.plugins:kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.csanchez.jenkins.plugins:kubernetes to 1.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000187 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

A exposure of sensitive information vulnerability exists in Jenkins Kubernetes Plugin 1.7.0 and older in ContainerExecDecorator.java that results in sensitive variables such as passwords being written to logs.
O3 Security · Impact-Aware SCA

Is CVE-2018-1000187 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1000187: kubernetes — Fixed in 1.7.1