NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2259 — computer-queue-plugin

MEDIUMFix: jenkinsci/computer-queue-plugin@38776c0

CVE-2020-2259 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in jenkins.ci.plugins.computerqueue:computer-queue-plugin. A fix is available for jenkins.ci.plugins.computerqueue:computer-queue-plugin — see the affected versions and patch details below.

Stored XSS vulnerability in computer-queue-plugin Plugin

Also known asGHSA-qg66-xv7v-m834
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕jenkins.ci.plugins.computerqueue:computer-queue-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

computer-queue-plugin Plugin 1.5 and earlier does not escape the agent name in tooltips.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.

computer-queue-plugin Plugin 1.6 escapes the agent name in tooltips.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenjenkins.ci.plugins.computerqueue:computer-queue-pluginall versions1.6jenkins.ci.plugins.computerqueue:computer-queue-plugin:1.6

Affected Products

1 product · 1 configurations
Application
computer queuejenkins
≤ 1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jenkins.ci.plugins.computerqueue:computer-queue-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jenkins.ci.plugins.computerqueue:computer-queue-plugin to 1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2259 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

computer-queue-plugin Plugin 1.5 and earlier does not escape the agent name in tooltips. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission. computer-queue-plugin Plugin 1.6 escapes the agent name in tooltips.
O3 Security · Impact-Aware SCA

Is CVE-2020-2259 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2259: computer-queue-plugin XSS — Fixed in 1.6