CVE-2020-20523 — gila
MEDIUMCVE-2020-20523 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in gilacms/gila. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for gilacms/gila — see the affected versions and patch details below.
Gila CMS Cross-site Scripting Vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2020-20523.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
gilacms/gilaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross Site Scripting (XSS) vulnerability in adm_user parameter in Gila CMS version 1.11.3, allows remote attackers to execute arbitrary code during the Gila CMS installation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | gilacms/gila | all versions | 1.11.4composer require gilacms/gila:^1.11.4 |
Affected Products
gila cmsgilacmsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gilacms/gila, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gilacms/gila to 1.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-20523 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-20523 in your dependencies?
Find it across Packagist, including transitive dependencies.