NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-15885 — comment

MEDIUMFix: munkireport/comment@ee4c1cd

CVE-2020-15885 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in munkireport/comment. A fix is available for munkireport/comment — see the affected versions and patch details below.

MunkiReport Cross-Site Scripting (XSS) Filter Bypass On Comment

Also known asGHSA-vc4f-2g7f-pmqr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.96%1.44%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘munkireport/comment

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A Cross-Site Scripting (XSS) vulnerability in the comment module before 4.0 for MunkiReport allows remote attackers to inject arbitrary web script or HTML by posting a new comment.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmunkireport/commentall versions4.0composer require munkireport/comment:^4.0

Affected Products

1 product · 1 configurations
Application
commentmunkireport_project
< 4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for munkireport/comment, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update munkireport/comment to 4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15885 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A Cross-Site Scripting (XSS) vulnerability in the comment module before 4.0 for MunkiReport allows remote attackers to inject arbitrary web script or HTML by posting a new comment.
O3 Security · Impact-Aware SCA

Is CVE-2020-15885 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-15885: comment XSS — Fixed in 4.0