NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-15873 — librenms

MEDIUMFix: librenms/librenms@8f3a29c

CVE-2020-15873 is a medium-severity (CVSS 6.5) SQL Injection vulnerability in librenms/librenms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for librenms/librenms — see the affected versions and patch details below.

LibreNMS SQL Injection vulnerability

Also known asGHSA-g5r6-vrmx-9gwj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.30%3.26%6.23%9.20%7.5%2.2%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘librenms/librenms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In LibreNMS before 1.65.1, an authenticated attacker can achieve SQL Injection via the customoid.inc.php device_id POST parameter to ajax_form.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlibrenms/librenmsall versions1.65.1composer require librenms/librenms:^1.65.1

Affected Products

1 product · 1 configurations
Application
librenmslibrenms
< 1.65.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for librenms/librenms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update librenms/librenms to 1.65.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15873 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

In LibreNMS before 1.65.1, an authenticated attacker can achieve SQL Injection via the customoid.inc.php device_id POST parameter to ajax_form.php.
O3 Security · Impact-Aware SCA

Is CVE-2020-15873 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-15873: librenms SQL Injection — Fixed in 1.65.1