CVE-2020-15517 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in tpwd/ke_search. A fix is available for tpwd/ke_search — see the affected versions and patch details below.
ke_search for Typo3 XSS Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tpwd/ke_search🐘tpwd/ke_searchReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The ke_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | tpwd/ke_search | ≥ 3.0.0&&< 3.1.4 | 3.1.4composer require tpwd/ke_search:^3.1.4 |
| 🐘Packagist | tpwd/ke_search | all versions | 2.8.3composer require tpwd/ke_search:^2.8.3 |
Affected Products
faceted searchfaceted_search_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tpwd/ke_search, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tpwd/ke_search to 3.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15517 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-15517 in your dependencies?
Find it across Packagist, including transitive dependencies.