NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2020-15186 — helm

LOWFix: helm/helm@809e2d9

CVE-2020-15186 is a low-severity (CVSS 2.7) Improper Input Validation vulnerability in helm.sh/helm/v3. A fix is available for helm.sh/helm/v3 — see the affected versions and patch details below.

Improper Sanitizing of plugin names in helm

Also known asBIT-helm-2020-15186GHSA-m54r-vrmv-hw33
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.97%1.46%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹helm.sh/helm/v3🐹helm.sh/helm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Security researchers at Trail of Bits discovered that plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to helm --help.

Specific Go Packages Affected

helm.sh/helm/v3/pkg/plugin

Patches

This issue has been patched in Helm 3.3.2.

Workarounds

Do not install untrusted Helm plugins. Examine the name field in the plugin.yaml file for a plugin, looking for characters outside of the [a-zA-Z0-9._-] range.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gohelm.sh/helm/v3≥ 3.0.0&&< 3.3.23.3.2go get helm.sh/helm/v3@v3.3.2
🐹Gohelm.sh/helmall versions2.16.11go get helm.sh/helm@v2.16.11

Affected Products

1 product · 2 configurations
Application
helmhelm
≥ 3.0.0 && < 3.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for helm.sh/helm/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update helm.sh/helm/v3 to 3.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-15186 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Security researchers at Trail of Bits discovered that plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to `helm --help`. ### Specific Go Packages Affected helm.sh/helm/v3/pkg/plugin ### Patches This issue has been patched in Helm 3.3.2. ### Workarounds Do not install untrusted Helm plugins. Examine the `name` field in the `plugin.yaml` file for a plugin, looking for characters outside of the [a-zA-Z
O3 Security · Impact-Aware SCA

Is CVE-2020-15186 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-15186: helm — Fixed in 3.3.2