NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2020-13942 — unomi

CRITICAL

CVE-2020-13942 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.apache.unomi:unomi. 13 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.unomi:unomi — see the affected versions and patch details below.

Injection and Improper Input Validation in Apache Unomi

Also known asGHSA-xp5j-wj4h-2jq9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
13 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
68.5%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
60.5%73.7%86.8%100.0%94.3%68.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.unomi:unomi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.unomi:unomiall versions1.5.2org.apache.unomi:unomi:1.5.2

Affected Products

1 product · 1 configurations
Application
unomiapache
≥ 1.5.0 && < 1.5.2
range
Exploits & PoCs
13

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.unomi:unomi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.unomi:unomi to 1.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13942 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2020-13942

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2020-13942 -u https://target
Template
Apache Unomi <1.5.2 - Remote Code Execution
Severity
critical
Impact
Successful exploitation of this vulnerability can allow an attacker to execute arbitrary code on the affected server.
Remediation
Apache Unomi users should upgrade to 1.5.2 or later.

Template by ProjectDiscovery nuclei-templates (dwisiswant0), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

It is possible to inject malicious OGNL or MVEL scripts into the /context.json public endpoint. This was partially fixed in 1.5.1 but a new attack vector was found. In Apache Unomi version 1.5.2 scripts are now completely filtered from the input. It is highly recommended to upgrade to the latest available version of the 1.5.x release to fix this problem.
O3 Security · Impact-Aware SCA

Is CVE-2020-13942 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-13942: unomi — Fixed in 1.5.2