CVE-2020-13663 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal Core Cross-Site Request Forgery (CSRF) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.9.0&&< 8.9.1 | 8.9.1composer require drupal/core:^8.9.1 |
| 🐘Packagist | drupal/core | ≥ 9.0.0&&< 9.0.1 | 9.0.1composer require drupal/core:^9.0.1 |
| 🐘Packagist | drupal/core | ≥ 7.0.0&&< 7.72 | 7.72composer require drupal/core:^7.72 |
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 8.8.8 | 8.8.8composer require drupal/core:^8.8.8 |
| 🐘Packagist | drupal/drupal | ≥ 7.0.0&&< 7.72 | 7.72composer require drupal/drupal:^7.72 |
| 🐘Packagist | drupal/drupal | ≥ 8.0.0&&< 8.8.8 | 8.8.8composer require drupal/drupal:^8.8.8 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13663 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-13663 in your dependencies?
Find it across Packagist, including transitive dependencies.