NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-7614 — elasticsearch

MEDIUM

CVE-2019-7614 is a medium-severity (CVSS 5.9) CWE-362 vulnerability in org.elasticsearch:elasticsearch. A fix is available for org.elasticsearch:elasticsearch — see the affected versions and patch details below.

Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch

Also known asGHSA-jqm6-m3j3-8gg9
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.51%0.84%1.17%1.51%1.0%1.0%1.0%1.0%Jul 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.elasticsearch:elasticsearch☕org.elasticsearch:elasticsearch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.elasticsearch:elasticsearchall versions6.8.2org.elasticsearch:elasticsearch:6.8.2
☕Mavenorg.elasticsearch:elasticsearch≥ 7.0.0&&< 7.2.17.2.1org.elasticsearch:elasticsearch:7.2.1

Affected Products

1 product · 2 configurations
Application
elasticsearchelastic
≥ 7.0.0 && < 7.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.elasticsearch:elasticsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.elasticsearch:elasticsearch to 6.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-7614 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
Workaround published by Red Hat
There is no mitigation for this issue, the flaw can only be resolved by applying updates.
Source: Red Hat security advisory for CVE-2019-7614 (CC BY 4.0)

Frequently Asked Questions

A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.
O3 Security · Impact-Aware SCA

Is CVE-2019-7614 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-7614: elasticsearch — Fixed in 6.8.2