NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-6588 — release.portal.bom

MEDIUM

CVE-2019-6588 is a medium-severity (CVSS 4.7) Cross-site Scripting (XSS) vulnerability in com.liferay.portal:release.portal.bom. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.

Liferay Portal Allows Cross-Site Scripting (XSS) via the SimpleCaptcha API

Also known asGHSA-hwp2-gvm5-452f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.19%1.06%1.93%2.80%0.7%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay.portal:release.portal.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Liferay Portal before 7.1 CE GA4, an XSS vulnerability exists in the SimpleCaptcha API when custom code passes unsanitized input into the "url" parameter of the JSP taglib call <liferay-ui:captcha url="<%= url %>" /> or <liferay-captcha:captcha url="<%= url %>" />. Liferay Portal out-of-the-box behavior with no customizations is not vulnerable.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.portal:release.portal.bomall versions7.1.0com.liferay.portal:release.portal.bom:7.1.0

Affected Products

1 product · 64 configurations
Application
liferay portalliferay
≤ 6.0.6
17 versions
6.1.06.1.16.1.26.2.06.2.16.2.26.2.36.2.46.2.57.0.07.0.17.0.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-46983webappsjsp

Liferay Portal 7.1 CE GA=3 / SimpleCaptcha API - Cross-Site Scripting

by Valerio Brussani · Jun 11, 2019

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay.portal:release.portal.bom to 7.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-6588 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Liferay Portal before 7.1 CE GA4, an XSS vulnerability exists in the SimpleCaptcha API when custom code passes unsanitized input into the "url" parameter of the JSP taglib call <liferay-ui:captcha url="<%= url %>" /> or <liferay-captcha:captcha url="<%= url %>" />. Liferay Portal out-of-the-box behavior with no customizations is not vulnerable.
O3 Security · Impact-Aware SCA

Is CVE-2019-6588 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-6588: release.portal.bom XSS — Fixed in 7.1.0