CVE-2019-6341 — core
MEDIUMCVE-2019-6341 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in drupal/core. EPSS puts its 30-day exploitation probability at 12.2% (96th percentile). A fix is available for drupal/core — see the affected versions and patch details below.
Drupal Cross Site Scripting (XSS) vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 7.0.0&&< 7.65.0 | 7.65.0composer require drupal/core:^7.65.0 |
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 8.5.14 | 8.5.14composer require drupal/core:^8.5.14 |
| 🐘Packagist | drupal/core | ≥ 8.6.0&&< 8.6.13 | 8.6.13composer require drupal/core:^8.6.13 |
| 🐘Packagist | drupal/drupal | ≥ 7.0.0&&< 7.65.0 | 7.65.0composer require drupal/drupal:^7.65.0 |
| 🐘Packagist | drupal/drupal | ≥ 8.0.0&&< 8.5.14 | 8.5.14composer require drupal/drupal:^8.5.14 |
| 🐘Packagist | drupal/drupal | ≥ 8.6.0&&< 8.6.13 | 8.6.13composer require drupal/drupal:^8.6.13 |
Affected Products
debian linuxdebiandrupaldrupalfedorafedoraprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 7.65.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-6341 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2019-6341 in your dependencies?
Find it across Packagist, including transitive dependencies.