NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2019-5885 — matrix-synapse

HIGHFix: matrix-org/synapse#4315

CVE-2019-5885 is a high-severity (CVSS 7.5) Insufficient Random Values vulnerability in matrix-synapse. A fix is available for matrix-synapse — see the affected versions and patch details below.

Matrix Synapse Predictable Secret Key

Also known asGHSA-jrqm-v8cv-53wwPYSEC-2019-187
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.5%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.26%1.17%2.09%3.00%0.8%2.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍matrix-synapse

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Matrix Synapse before 0.34.0.1, when the macaroon_secret_key authentication parameter is not set, uses a predictable value to derive a secret key and other secrets which could allow remote attackers to impersonate users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImatrix-synapseall versions0.34.0.1pip install --upgrade 'matrix-synapse==0.34.0.1'

Affected Products

2 products · 3 configurations
OS
fedorafedoraproject
2 versions
2829
Application
synapsematrix
< 0.34.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-synapse, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update matrix-synapse to 0.34.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-5885 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Matrix Synapse before 0.34.0.1, when the macaroon_secret_key authentication parameter is not set, uses a predictable value to derive a secret key and other secrets which could allow remote attackers to impersonate users.
O3 Security · Impact-Aware SCA

Is CVE-2019-5885 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-5885: matrix-synapse — Fixed in 0.34.0.1