NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-3797 — spring-data-jpa

MEDIUM

CVE-2019-3797 is a medium-severity (CVSS 5.3) SQL Injection vulnerability in org.springframework.data:spring-data-jpa. A fix is available for org.springframework.data:spring-data-jpa — see the affected versions and patch details below.

Exposure of Sensitive Information to an Unauthorized Actor and SQL Injection in Spring Data JPA

Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.53%1.06%1.59%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.springframework.data:spring-data-jpa☕org.springframework.data:spring-data-jpa☕org.springframework.data:spring-data-jpa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

This affects Spring Data JPA in versions up to and including 2.1.5, 2.0.13 and 1.11.19. Derived queries using any of the predicates ?startingWith?, ?endingWith? or ?containing? could return more results than anticipated when a maliciously crafted query parameter value is supplied. Also, LIKE expressions in manually defined queries could return unexpected results if the parameter values bound did not have escaped reserved characters properly.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.data:spring-data-jpaall versions1.11.20org.springframework.data:spring-data-jpa:1.11.20
☕Mavenorg.springframework.data:spring-data-jpa≥ 2.0.0&&< 2.0.142.0.14org.springframework.data:spring-data-jpa:2.0.14
☕Mavenorg.springframework.data:spring-data-jpa≥ 2.1.0&&< 2.1.62.1.6org.springframework.data:spring-data-jpa:2.1.6

Affected Products

1 product · 3 configurations
Application
spring data java persistence apipivotal_software
≥ 2.1.0 && ≤ 2.1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.data:spring-data-jpa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.data:spring-data-jpa to 1.11.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3797 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat Fuse 7.7.0spring-data-jpaRHSA-2020:3192

Frequently Asked Questions

This affects Spring Data JPA in versions up to and including 2.1.5, 2.0.13 and 1.11.19. Derived queries using any of the predicates ?startingWith?, ?endingWith? or ?containing? could return more results than anticipated when a maliciously crafted query parameter value is supplied. Also, LIKE expressions in manually defined queries could return unexpected results if the parameter values bound did not have escaped reserved characters properly.
O3 Security · Impact-Aware SCA

Is CVE-2019-3797 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-3797: spring-data-jpa — Fixed in 1.11.20