NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2016-6652 — spring-data-jpa

MEDIUM

CVE-2016-6652 is a medium-severity (CVSS 5.6) SQL Injection vulnerability in org.springframework.data:spring-data-jpa. A fix is available for org.springframework.data:spring-data-jpa — see the affected versions and patch details below.

Improper Neutralization of Special Elements used in an SQL Command Pivotal Spring Data JPA

Also known asGHSA-xr4v-28rm-pvgw
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework.data:spring-data-jpa☕org.springframework.data:spring-data-jpa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

SQL injection vulnerability in Pivotal Spring Data JPA before 1.9.6 (Gosling SR6) and 1.10.x before 1.10.4 (Hopper SR4), when used with a repository that defines a String query using the @Query annotation, allows attackers to execute arbitrary JPQL commands via a sort instance with a function call.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.data:spring-data-jpaall versions1.9.6org.springframework.data:spring-data-jpa:1.9.6
☕Mavenorg.springframework.data:spring-data-jpa≥ 1.10.0&&< 1.10.41.10.4org.springframework.data:spring-data-jpa:1.10.4

Affected Products

1 product · 2 configurations
Application
spring data jpapivotal_software
≤ 1.9.4
1 version
1.10.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.data:spring-data-jpa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.data:spring-data-jpa to 1.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-6652 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

SQL injection vulnerability in Pivotal Spring Data JPA before 1.9.6 (Gosling SR6) and 1.10.x before 1.10.4 (Hopper SR4), when used with a repository that defines a String query using the @Query annotation, allows attackers to execute arbitrary JPQL commands via a sort instance with a function call.
O3 Security · Impact-Aware SCA

Is CVE-2016-6652 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-6652: spring-data SQL Injection — Fixed in 1.9.6