NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2019-3465 — xmlseclibs

HIGHFix: robrichards/xmlseclibs@0a53d3c

CVE-2019-3465 is a high-severity (CVSS 8.8) CWE-347 vulnerability in robrichards/xmlseclibs. A fix is available for robrichards/xmlseclibs — see the affected versions and patch details below.

Signature validation bypass in XmlSecLibs

Also known asGHSA-pqm6-cgwr-x6pf
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.37%2.09%2.81%3.52%1.9%3.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘robrichards/xmlseclibs🐘robrichards/xmlseclibs

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistrobrichards/xmlseclibs≥ 3.0.0&&< 3.0.43.0.4composer require robrichards/xmlseclibs:^3.0.4
🐘Packagistrobrichards/xmlseclibs≥ 1.0.0&&< 2.1.12.1.1composer require robrichards/xmlseclibs:^2.1.1

Affected Products

3 products · 7 configurations
OS
debian linuxdebian
3 versions
8.09.010.0
Application
simplesamlphpsimplesamlphp
≤ 1.17.6
range
Application
xmlseclibsxmlseclibs_project
≥ 3.0.0 && ≤ 3.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for robrichards/xmlseclibs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update robrichards/xmlseclibs to 3.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3465 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.
O3 Security · Impact-Aware SCA

Is CVE-2019-3465 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2019-3465: xmlseclibs — Fixed in 3.0.4