NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-25095 — ldapcherry

MEDIUMFix: kakwa/ldapcherry@6f98076

CVE-2019-25095 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ldapcherry. A fix is available for ldapcherry — see the affected versions and patch details below.

LdapCherry Cross-site Scripting vulnerbaility

Also known asGHSA-vq8w-x8v7-f88mPYSEC-2023-19
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍ldapcherry

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability, which was classified as problematic, was found in kakwa LdapCherry up to 0.x. Affected is an unknown function of the component URL Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 6f98076281e9452fdb1adcd1bcbb70a6f968ade9. It is recommended to upgrade the affected component. VDB-217434 is the identifier assigned to this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIldapcherryall versions1.0.0pip install --upgrade 'ldapcherry==1.0.0'

Affected Products

1 product · 1 configurations
Application
ldapcherryldapcherry_project
< 1.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ldapcherry, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ldapcherry to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-25095 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A vulnerability, which was classified as problematic, was found in kakwa LdapCherry up to 0.x. Affected is an unknown function of the component URL Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 6f98076281e9452fdb1adcd1bcbb70a6f968ade9. It is recommended to upgrade the affected component. VDB-217434 is the identifier assigned to this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2019-25095 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-25095: ldapcherry XSS — Fixed in 1.0.0