CVE-2019-20933 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in github.com/influxdata/influxdb. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/influxdata/influxdb — see the affected versions and patch details below.
Improper Authentication in InfluxDB
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/influxdata/influxdbReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate function in services/httpd/handler.go because a JWT token may have an empty SharedSecret (aka shared secret).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/influxdata/influxdb | all versions | 1.7.6go get github.com/influxdata/influxdb@v1.7.6 |
Affected Products
debian linuxdebianinfluxdbinfluxdataResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/influxdata/influxdb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/influxdata/influxdb to 1.7.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-20933 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2019-20933
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2019-20933 -u https://target- Template
- InfluxDB <1.7.6 - Authentication Bypass
- Severity
- critical
- Impact
- An attacker can bypass authentication and gain unauthorized access to the InfluxDB database.
- Remediation
- Update Influxdb to version 1.7.6~rc0-1 or higher.
Template by ProjectDiscovery nuclei-templates (pussycat0x, c-sh0), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
For versions before 1.7.6, as per the documentation updated by influxdb, ensure that a default shared-secret has be defined when enabling JWT authentication: https://docs.influxdata.com/influxdb/v1.8/administration/authentication_and_authorization/#1-add-a-shared-secret-in-your-influxdb-configuration-file Versions including the fix will return an error if the secret is left empty.Source: Red Hat security advisory for CVE-2019-20933 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2019-20933 in your dependencies?
Find it across Go, including transitive dependencies.