NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2018-17572 — influxdb

MEDIUM

CVE-2018-17572 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in github.com/influxdata/influxdb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/influxdata/influxdb — see the affected versions and patch details below.

InfluxDB Reflected Cross-site Scripting

Also known asGHSA-w55x-q3gv-px85
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/influxdata/influxdb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

InfluxDB 0.9.5 has Reflected XSS in the admin panel via the Write Data module.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/influxdata/influxdball versions0.9.6go get github.com/influxdata/influxdb@v0.9.6

Affected Products

1 product · 1 configurations
Application
influxdbinfluxdata
≤ 0.9.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/influxdata/influxdb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/influxdata/influxdb to 0.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-17572 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

InfluxDB 0.9.5 has Reflected XSS in the admin panel via the Write Data module.
O3 Security · Impact-Aware SCA

Is CVE-2018-17572 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2018-17572: influxdb XSS — Fixed in 0.9.6