NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2019-19450 — reportlab

CRITICAL

CVE-2019-19450 is a critical-severity (CVSS 9.8) CWE-91 vulnerability in reportlab. A fix is available for reportlab — see the affected versions and patch details below.

ReportLab vulnerable to remote code execution via paraparser

Also known asGHSA-pj98-2xf6-cff5PYSEC-2026-522
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
2.94%5.63%8.31%11.0%9.5%6.0%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍reportlab

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

paraparser in ReportLab before 3.5.31 allows remote code execution because start_unichar in paraparser.py evaluates untrusted user input in a unichar element in a crafted XML document with '<unichar code="' followed by arbitrary Python code, a similar issue to CVE-2019-17626.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIreportlaball versions3.5.31pip install --upgrade 'reportlab==3.5.31'

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
10.0
Application
reportlabreportlab
< 3.5.31
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for reportlab, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update reportlab to 3.5.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-19450 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

To exploit the issue, a malicious user has to use a crafted malicious html 'unichar' tag input and then use the reportlab's feature to generate a pdf of the document and that can lead to a remote code execution, therefore, this CVE has an Important impact. This vulnerability is similar to CVE-2019-17626.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2019-19450 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 7python-reportlab-0:2.5-11.el7_9RHSA-2023:5616
Red Hat Enterprise Linux 8python-reportlab-0:3.4.0-8.el8_8.1RHSA-2023:5790
Red Hat Enterprise Linux 8.1 Update Services for SAP Solutionspython-reportlab-0:3.4.0-6.el8_1.5RHSA-2023:5789
Red Hat Enterprise Linux 8.2 Advanced Update Supportpython-reportlab-0:3.4.0-8.el8_2.1RHSA-2023:5788
Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Supportpython-reportlab-0:3.4.0-8.el8_4.1RHSA-2023:5787
Red Hat Enterprise Linux 8.6 Extended Update Supportpython-reportlab-0:3.4.0-8.el8_6.1RHSA-2023:5786

Frequently Asked Questions

paraparser in ReportLab before 3.5.31 allows remote code execution because start_unichar in paraparser.py evaluates untrusted user input in a unichar element in a crafted XML document with '<unichar code="' followed by arbitrary Python code, a similar issue to CVE-2019-17626.
O3 Security · Impact-Aware SCA

Is CVE-2019-19450 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-19450: reportlab RCE — Fixed in 3.5.31