CVE-2019-17626 — reportlab
CRITICALCVE-2019-17626 is a critical-severity (CVSS 9.8) CWE-91 vulnerability in reportlab. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for reportlab — see the affected versions and patch details below.
XML Injection in ReportLab
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2019-17626.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
reportlabReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
ReportLab through 3.5.26 allows remote code execution because of toColor(eval(arg)) in colors.py, as demonstrated by a crafted XML document with '<span color="' followed by arbitrary Python code.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | reportlab | all versions | 3.5.28pip install --upgrade 'reportlab==3.5.28' |
Affected Products
reportlabreportlabResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for reportlab, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update reportlab to 3.5.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17626 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability will not be fixed in Red Hat Quay because it only affects a non-supported feature which is disabled behind a feature flag.
No known mitigation available.Source: Red Hat security advisory for CVE-2019-17626 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | python-reportlab-0:2.3-3.el6_10.1 | RHSA-2020:0197 |
| Red Hat Enterprise Linux 7 | python-reportlab-0:2.5-9.el7_7.1 | RHSA-2020:0195 |
| Red Hat Enterprise Linux 8 | python-reportlab-0:3.4.0-6.el8_1.2 | RHSA-2020:0201 |
| Red Hat Enterprise Linux 8.0 Update Services for SAP Solutions | python-reportlab-0:3.4.0-6.el8_0.2 | RHSA-2020:0230 |
Frequently Asked Questions
Is CVE-2019-17626 in your dependencies?
Find it across PyPI, including transitive dependencies.