NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-19040 — kairosdb

MEDIUMFix: kairosdb/kairosdb#593

CVE-2019-19040 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.kairosdb:kairosdb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.kairosdb:kairosdb — see the affected versions and patch details below.

Reflected Cross site scripting (XSS) in kairosdb

Also known asGHSA-fjhh-67wv-7gr4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.45%0.90%1.36%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.kairosdb:kairosdb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

KairosDB through 1.2.2 has XSS in view.html because of showErrorMessage in js/graph.js, as demonstrated by view.html?q= with a '"sampling":{"value":"<script>' substring.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.kairosdb:kairosdball versions1.3.0org.kairosdb:kairosdb:1.3.0

Affected Products

1 product · 1 configurations
Application
kairosdbkairosdb_project
≤ 1.2.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.kairosdb:kairosdb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.kairosdb:kairosdb to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-19040 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

KairosDB through 1.2.2 has XSS in view.html because of showErrorMessage in js/graph.js, as demonstrated by view.html?q= with a '"sampling":{"value":"<script>' substring.
O3 Security · Impact-Aware SCA

Is CVE-2019-19040 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-19040: kairosdb XSS — Fixed in 1.3.0