CVE-2019-18887 — http-kernel
HIGHCVE-2019-18887 is a high-severity (CVSS 8.1) CWE-203 vulnerability in symfony/http-kernel. A fix is available for symfony/http-kernel — see the affected versions and patch details below.
Symfony Http-Kernel has non-constant time comparison in UriSigner
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/http-kernel🐘symfony/http-kernel🐘symfony/http-kernel🐘symfony/http-kernel🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Symfony 2.8.0 through 2.8.50, 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. The UriSigner was subject to timing attacks. This is related to symfony/http-kernel.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/http-kernel | ≥ 2.2.0&&< 2.8.52 | 2.8.52composer require symfony/http-kernel:^2.8.52 |
| 🐘Packagist | symfony/http-kernel | ≥ 3.0.0&&< 3.4.35 | 3.4.35composer require symfony/http-kernel:^3.4.35 |
| 🐘Packagist | symfony/http-kernel | ≥ 4.0.0&&< 4.2.12 | 4.2.12composer require symfony/http-kernel:^4.2.12 |
| 🐘Packagist | symfony/http-kernel | ≥ 4.3.0&&< 4.3.8 | 4.3.8composer require symfony/http-kernel:^4.3.8 |
| 🐘Packagist | symfony/symfony | ≥ 2.2.0&&< 2.8.52 | 2.8.52composer require symfony/symfony:^2.8.52 |
| 🐘Packagist | symfony/symfony | ≥ 3.0.0&&< 3.4.35 | 3.4.35composer require symfony/symfony:^3.4.35 |
Affected Products
fedorafedoraprojectsymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/http-kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/http-kernel to 2.8.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-18887 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-18887 in your dependencies?
Find it across Packagist, including transitive dependencies.