CVE-2015-4050 — http-kernel
CVE-2015-4050 is a CWE-284 vulnerability in symfony/http-kernel. A fix is available for symfony/http-kernel — see the affected versions and patch details below.
Symfony Incorrect Access Control
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
symfony/http-kernel🐘symfony/http-kernel🐘symfony/http-kernel🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/http-kernelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0 through 2.6.7, when ESI or SSI support enabled, does not check if the _controller attribute is set, which allows remote attackers to bypass URL signing and security rules by including (1) no hash or (2) an invalid hash in a request to /_fragment.
This issue has been fixed in Symfony 2.3.29, 2.5.12, and 2.6.8. Note that no fixes are provided for Symfony 2.4 as it's not maintained anymore.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/http-kernel | ≥ 2.3.19&&< 2.3.29 | 2.3.29composer require symfony/http-kernel:^2.3.29 |
| 🐘Packagist | symfony/http-kernel | ≥ 2.5.4&&< 2.5.12 | 2.5.12composer require symfony/http-kernel:^2.5.12 |
| 🐘Packagist | symfony/http-kernel | ≥ 2.6.0&&< 2.6.8 | 2.6.8composer require symfony/http-kernel:^2.6.8 |
| 🐘Packagist | symfony/symfony | ≥ 2.3.19&&< 2.3.29 | 2.3.29composer require symfony/symfony:^2.3.29 |
| 🐘Packagist | symfony/symfony | ≥ 2.4.9 | No fix |
| 🐘Packagist | symfony/symfony | ≥ 2.5.4&&< 2.5.12 | 2.5.12composer require symfony/symfony:^2.5.12 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/http-kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/http-kernel to 2.3.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-4050 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2015-4050
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2015-4050 -u https://target- Template
- Symfony - Authentication Bypass
- Severity
- medium
- Impact
- Successful exploitation of this vulnerability could allow an attacker to bypass authentication and gain unauthorized access to the affected system.
- Remediation
- Apply the latest security patches or upgrade to a non-vulnerable version of Symfony.
Template by ProjectDiscovery nuclei-templates (ELSFA7110, meme-lord), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2015-4050 in your dependencies?
Find it across Packagist, including transitive dependencies.