NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2019-18835 — matrix-synapse

CRITICALFix: matrix-org/synapse#6262

CVE-2019-18835 is a critical-severity (CVSS 9.8) CWE-345 vulnerability in matrix-synapse. A fix is available for matrix-synapse — see the affected versions and patch details below.

Improper Verification of Cryptographic Signature in matrix-synapse

Also known asGHSA-cppw-2mf8-qpm5PYSEC-2019-186
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍matrix-synapse

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImatrix-synapseall versions1.5.0pip install --upgrade 'matrix-synapse==1.5.0'

Affected Products

1 product · 1 configurations
Application
synapsematrix
< 1.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-synapse, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update matrix-synapse to 1.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-18835 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
O3 Security · Impact-Aware SCA

Is CVE-2019-18835 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-18835: matrix-synapse — Fixed in 1.5.0