CVE-2019-18658 — helm
CRITICALCVE-2019-18658 is a critical-severity (CVSS 9.8) CWE-59 vulnerability in helm.sh/helm. A fix is available for helm.sh/helm — see the affected versions and patch details below.
Helm Unsafe Link Following
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
helm.sh/helmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | helm.sh/helm | ≥ 2.0.0&&< 2.15.2 | 2.15.2go get helm.sh/helm@v2.15.2 |
Affected Products
helmhelmDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for helm.sh/helm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update helm.sh/helm to 2.15.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-18658 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2019-18658 in your dependencies?
Find it across Go, including transitive dependencies.