CVE-2019-17106 is a medium-severity (CVSS 6.5) CWE-312 vulnerability in centreon/centreon. A fix is available for centreon/centreon — see the affected versions and patch details below.
Centreon Sensitive Data Exposure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
centreon/centreonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Centreon Web through 2.8.29, disclosure of external components' passwords allows authenticated attackers to move laterally to external components.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | centreon/centreon | all versions | 2.8.30composer require centreon/centreon:^2.8.30 |
Affected Products
centreon webcentreonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for centreon/centreon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update centreon/centreon to 2.8.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-17106 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2019-17106 in your dependencies?
Find it across Packagist, including transitive dependencies.