CVE-2022-40043 is a high-severity (CVSS 8.8) SQL Injection vulnerability in centreon/centreon. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for centreon/centreon — see the affected versions and patch details below.
Centreon SQL Injection vulnerability via esc_name parameter
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-40043.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
centreon/centreon🐘centreon/centreon🐘centreon/centreonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Centreon v20.10.18 was discovered to contain a SQL injection vulnerability via the esc_name (Escalation Name) parameter at Configuration/Notifications/Escalations. Versions 21.04.16, 21.10.8, and 22.04.2 contain patches.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | centreon/centreon | all versions | 21.04.16composer require centreon/centreon:^21.04.16 |
| 🐘Packagist | centreon/centreon | ≥ 21.10.0&&< 21.10.8 | 21.10.8composer require centreon/centreon:^21.10.8 |
| 🐘Packagist | centreon/centreon | ≥ 22.0.0&&< 22.04.2 | 22.04.2composer require centreon/centreon:^22.04.2 |
Affected Products
centreoncentreonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for centreon/centreon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update centreon/centreon to 21.04.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-40043 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-40043 in your dependencies?
Find it across Packagist, including transitive dependencies.