NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-16791 — postfix-mta-sts-resolver

MEDIUM

CVE-2019-16791 is a medium-severity (CVSS 5.9) CWE-757 vulnerability in postfix-mta-sts-resolver. A fix is available for postfix-mta-sts-resolver — see the affected versions and patch details below.

postfix-mta-sts-resolver Algorithm Downgrade vulnerability

Also known asGHSA-h92m-42h4-82f6PYSEC-2020-174
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.07%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.3%0.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍postfix-mta-sts-resolver

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Incorrect query parsing

Impact

All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Patches

Problem has been patched in version 0.5.1

Workarounds

Users may remediate this vulnerability without upgrading by applying these patches to older suppoorted versions.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpostfix-mta-sts-resolverall versions0.5.1pip install --upgrade 'postfix-mta-sts-resolver==0.5.1'

Affected Products

1 product · 1 configurations
Application
postfix-mta-sts-resolverpostfix-mta-sts-resolver_project
< 0.5.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for postfix-mta-sts-resolver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update postfix-mta-sts-resolver to 0.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16791 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Incorrect query parsing ### Impact All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy. ### Patches Problem has been patched in version 0.5.1 ### Workarounds Users may remediate this vulnerability without upgrading by applying [these patches](https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b) to older suppoorted versions. ### For more information If you have any questions or comments about this advisory: * Open an issue in [postfix-mta-sts-resolver repo](https://github.com/Snawo
O3 Security · Impact-Aware SCA

Is CVE-2019-16791 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-16791: postfix-mta-sts-resolver — Fixed in 0.5.1