CVE-2019-15715 is a high-severity (CVSS 7.2) OS Command Injection vulnerability in mantisbt/mantisbt. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mantisbt/mantisbt — see the affected versions and patch details below.
MantisBT Remote Code Execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mantisbt/mantisbt🐘mantisbt/mantisbtReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mantisbt/mantisbt | all versions | 1.3.20composer require mantisbt/mantisbt:^1.3.20 |
| 🐘Packagist | mantisbt/mantisbt | ≥ 2.0.0&&< 2.22.1 | 2.22.1composer require mantisbt/mantisbt:^2.22.1 |
Affected Products
mantisbtmantisbtResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Mantis Bug Tracker 2.3.0 - Remote Code Execution (Unauthenticated)
by Nikolas Geiselman · Sep 18, 2020
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mantisbt/mantisbt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mantisbt/mantisbt to 1.3.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15715 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2019-15715 in your dependencies?
Find it across Packagist, including transitive dependencies.