NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-15488 — xmppserver

MEDIUMFix: igniterealtime/Openfire#1441

CVE-2019-15488 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.igniterealtime.openfire:xmppserver. A fix is available for org.igniterealtime.openfire:xmppserver — see the affected versions and patch details below.

Cross-site Scripting in Ignite Realtime Openfire

Also known asGHSA-5qfv-rr79-chx5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.igniterealtime.openfire:xmppserver

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Ignite Realtime Openfire before 4.4.1 has reflected XSS via an LDAP setup test.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.igniterealtime.openfire:xmppserverall versions4.4.1org.igniterealtime.openfire:xmppserver:4.4.1

Affected Products

1 product · 1 configurations
Application
openfireigniterealtime
< 4.4.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.igniterealtime.openfire:xmppserver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.igniterealtime.openfire:xmppserver to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-15488 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Ignite Realtime Openfire before 4.4.1 has reflected XSS via an LDAP setup test.
O3 Security · Impact-Aware SCA

Is CVE-2019-15488 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-15488: xmppserver XSS — Fixed in 4.4.1