NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2019-14271 — docker

CRITICALFix: moby/moby#39612

CVE-2019-14271 is a critical-severity (CVSS 9.8) CWE-665 vulnerability in github.com/docker/docker. EPSS puts its 30-day exploitation probability at 18.8% (97th percentile). A fix is available for github.com/docker/docker — see the affected versions and patch details below.

Moby Docker cp broken with debian containers

Also known asGHSA-v2cv-wwxq-qq97GO-2024-2521
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
18.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
2.82%31.3%59.7%88.2%72.2%18.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/docker/docker

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/docker/docker≥ 19.03.0&&< 19.03.119.03.1go get github.com/docker/docker@v19.03.1

Affected Products

3 products · 4 configurations
OS
debian linuxdebian
1 version
10.0
Application
dockerdocker
≥ 19.03 && < 19.03.1
range
OS
leapopensuse
2 versions
15.015.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/docker/docker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/docker/docker to 19.03.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14271 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

In Docker 19.03.x before 19.03.1 linked against the GNU C Library (aka glibc), code injection can occur when the nsswitch facility dynamically loads a library inside a chroot that contains the contents of the container.
O3 Security · Impact-Aware SCA

Is CVE-2019-14271 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2019-14271: docker RCE — Fixed in 19.03.1