NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2019-1302 — Microsoft.AspNetCore.SpaS…

HIGH

CVE-2019-1302 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in Microsoft.AspNetCore.SpaServices. A fix is available for Microsoft.AspNetCore.SpaServices — see the affected versions and patch details below.

Elevation of privilege in ASP.NET Core

Also known asGHSA-xr8f-59pp-rxxh
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
2.91%5.78%8.65%11.5%9.9%4.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
.NETMicrosoft.AspNetCore.SpaServices.NETMicrosoft.AspNetCore.SpaServices

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

An elevation of privilege vulnerability exists when a ASP.NET Core web application, created using vulnerable project templates, fails to properly sanitize web requests, aka 'ASP.NET Core Elevation Of Privilege Vulnerability'.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.SpaServices≥ 2.2.0&&< 2.2.72.2.7dotnet add package Microsoft.AspNetCore.SpaServices --version 2.2.7
.NETNuGetMicrosoft.AspNetCore.SpaServices≥ 2.1.0&&< 2.1.132.1.13dotnet add package Microsoft.AspNetCore.SpaServices --version 2.1.13

Affected Products

1 product · 3 configurations
Application
asp.net coremicrosoft
3 versions
2.12.23.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.SpaServices, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.SpaServices to 2.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-1302 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An elevation of privilege vulnerability exists when a ASP.NET Core web application, created using vulnerable project templates, fails to properly sanitize web requests, aka 'ASP.NET Core Elevation Of Privilege Vulnerability'.
O3 Security · Impact-Aware SCA

Is CVE-2019-1302 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2019-1302: Microsoft.AspNetCore — Fixed in 2.2.7