CVE-2019-12387 is a medium-severity (CVSS 6.1) CWE-74 vulnerability in twisted. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for twisted — see the affected versions and patch details below.
Twisted CRLF Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
twistedReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Twisted before 19.2.1, twisted.web did not validate or sanitize URIs or HTTP methods, allowing an attacker to inject invalid characters such as CRLF.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | twisted | all versions | 19.2.1pip install --upgrade 'twisted==19.2.1' |
Affected Products
ubuntu linuxcanonicalfedorafedoraprojectsolarisoraclezfs storage appliance kitoracletwistedtwistedResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for twisted, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update twisted to 19.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12387 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
* This issue does not affect Red Hat Gluster Storage 3 and Red Hat Ceph Storage 2 and 3 because these products do not use the twisted web APIs. * This issue does affect Red Hat Enterprise Linux 6. However, because this version is now in Maintenance Support 2 Phase and the flaw has a security impact of Moderate, it is…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | python-twisted-web-0:12.1.0-6.el7 | RHSA-2020:1091 |
| Red Hat Satellite 6.6 for RHEL 7 | ansiblerole-foreman_scap_client-0:0.0.3-1.el7sat | RHSA-2019:3172 |
Frequently Asked Questions
Is CVE-2019-12387 in your dependencies?
Find it across PyPI, including transitive dependencies.