CVE-2019-12245 — framework
MEDIUMCVE-2019-12245 is a medium-severity (CVSS 5.3) CWE-732 vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Lack of access control on upoaded files
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/framework🐘silverstripe/framework🐘silverstripe/assets🐘silverstripe/assetsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SilverStripe through 4.3.3 has incorrect access control for protected files uploaded via Upload::loadIntoFile(). An attacker may be able to guess a filename in silverstripe/assets via the AssetControlExtension.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | all versions | 3.6.8composer require silverstripe/framework:^3.6.8 |
| 🐘Packagist | silverstripe/framework | ≥ 3.7.0&&< 3.7.4 | 3.7.4composer require silverstripe/framework:^3.7.4 |
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0&&< 4.3.6 | 4.3.6composer require silverstripe/framework:^4.3.6 |
| 🐘Packagist | silverstripe/framework | ≥ 4.4.0&&< 4.4.4 | 4.4.4composer require silverstripe/framework:^4.4.4 |
| 🐘Packagist | silverstripe/assets | ≥ 1.0.0&&< 1.3.5 | 1.3.5composer require silverstripe/assets:^1.3.5 |
| 🐘Packagist | silverstripe/assets | ≥ 1.4.0&&< 1.4.4 | 1.4.4composer require silverstripe/assets:^1.4.4 |
Affected Products
silverstripesilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.6.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12245 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2019-12245 in your dependencies?
Find it across Packagist, including transitive dependencies.