NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2019-10249 — org.eclipse.xtext

HIGHFix: eclipse/xtext-xtend@169de2c

CVE-2019-10249 is a high-severity (CVSS 8.1) CWE-494 vulnerability in org.eclipse.xtext:org.eclipse.xtext. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.eclipse.xtext:org.eclipse.xtext — see the affected versions and patch details below.

Potentially compromised builds

Also known asGHSA-rfj2-4g26-7jw5
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.77%1.15%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.eclipse.xtext:org.eclipse.xtext☕org.eclipse.xtend:org.eclipse.xtend.core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

All Xtext & Xtend versions prior to 2.18.0 were built using HTTP instead of HTTPS file transfer and thus the built artifacts may have been compromised.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.eclipse.xtext:org.eclipse.xtextall versions2.18.0org.eclipse.xtext:org.eclipse.xtext:2.18.0
☕Mavenorg.eclipse.xtend:org.eclipse.xtend.coreall versions2.18.0org.eclipse.xtend:org.eclipse.xtend.core:2.18.0

Affected Products

2 products · 2 configurations
Application
xtendeclipse
< 2.18.0
range
Application
xtexteclipse
< 2.18.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.xtext:org.eclipse.xtext, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.eclipse.xtext:org.eclipse.xtext to 2.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10249 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

All Xtext & Xtend versions prior to 2.18.0 were built using HTTP instead of HTTPS file transfer and thus the built artifacts may have been compromised.
O3 Security · Impact-Aware SCA

Is CVE-2019-10249 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10249: org.eclipse.xtext — Fixed in 2.18.0