CVE-2019-10141 is a critical-severity (CVSS 9.1) SQL Injection vulnerability in ironic-inspector. A fix is available for ironic-inspector — see the affected versions and patch details below.
Openstack ironic-inspector has SQL injection vulnerability in node_cache
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ironic-inspector🐍ironic-inspector🐍ironic-inspector🐍ironic-inspector🐍ironic-inspectorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in openstack-ironic-inspector all versions excluding 5.0.2, 6.0.3, 7.2.4, 8.0.3 and 8.2.1. A SQL-injection vulnerability was found in openstack-ironic-inspector's node_cache.find_node(). This function makes a SQL query using unfiltered data from a server reporting inspection results (by a POST to the /v1/continue endpoint). Because the API is unauthenticated, the flaw could be exploited by an attacker with access to the network on which ironic-inspector is listening. Because of how ironic-inspector uses the query results, it is unlikely that data could be obtained. However, the attacker could pass malicious data and create a denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ironic-inspector | all versions | 5.0.2pip install --upgrade 'ironic-inspector==5.0.2' |
| 🐍PyPI | ironic-inspector | ≥ 5.1.0&&< 6.0.3 | 6.0.3pip install --upgrade 'ironic-inspector==6.0.3' |
| 🐍PyPI | ironic-inspector | ≥ 6.1.0&&< 7.2.4 | 7.2.4pip install --upgrade 'ironic-inspector==7.2.4' |
| 🐍PyPI | ironic-inspector | ≥ 8.0.0&&< 8.0.3 | 8.0.3pip install --upgrade 'ironic-inspector==8.0.3' |
| 🐍PyPI | ironic-inspector | ≥ 8.1.0&&< 8.2.1 | 8.2.1pip install --upgrade 'ironic-inspector==8.2.1' |
Affected Products
ironic-inspectoropenstackopenstackredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic-inspector, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ironic-inspector to 5.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10141 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 10.0 (Newton) | openstack-ironic-inspector-0:4.2.2-6.el7ost | RHSA-2019:1722 |
| Red Hat OpenStack Platform 13.0 (Queens) | openstack-ironic-inspector-0:7.2.3-3.el7ost | RHSA-2019:1734 |
| Red Hat OpenStack Platform 14.0 (Rocky) | openstack-ironic-inspector-0:8.0.3-0.20190420013817.el7ost | RHSA-2019:1669 |
| Red Hat OpenStack Platform 9.0 (Mitaka) director | openstack-ironic-inspector-0:3.2.2-5.el7ost | RHSA-2019:2505 |
Frequently Asked Questions
Is CVE-2019-10141 in your dependencies?
Find it across PyPI, including transitive dependencies.