NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2015-5306 — python-ironic-inspector-c…

HIGH

CVE-2015-5306 is a high-severity (CVSS 8.1) CWE-254 vulnerability in python-ironic-inspector-client. A fix is available for python-ironic-inspector-client — see the affected versions and patch details below.

Injection vulnerability that affects ironic-discoverd

Also known asGHSA-x64g-wjmw-w328PYSEC-2015-28PYSEC-2026-505
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.07%0.75%1.42%2.10%0.6%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍python-ironic-inspector-client🐍ironic-inspector

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Ironic Inspector (aka ironic-inspector or ironic-discoverd), when debug mode is enabled, might allow remote attackers to access the Flask console and execute arbitrary Python code by triggering an error.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-ironic-inspector-clientall versions0.2.5pip install --upgrade 'python-ironic-inspector-client==0.2.5'
🐍PyPIironic-inspectorall versions2.2.2pip install --upgrade 'ironic-inspector==2.2.2'

Affected Products

1 product · 1 configurations
Application
ironic inspectoropenstack
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-ironic-inspector-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-ironic-inspector-client to 0.2.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-5306 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7openstack-ironic-discoverd-0:0.2.5-2.el7ostRHSA-2015:2685
Red Hat Enterprise Linux OpenStack Platform director 7.0 for RHEL 7openstack-ironic-discoverd-0:1.1.0-8.el7ostRHSA-2015:1929

Frequently Asked Questions

OpenStack Ironic Inspector (aka ironic-inspector or ironic-discoverd), when debug mode is enabled, might allow remote attackers to access the Flask console and execute arbitrary Python code by triggering an error.
O3 Security · Impact-Aware SCA

Is CVE-2015-5306 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-5306: python-ironic-inspector-c… — Fixed in 0.2.5