NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2019-10070 — apache-atlas

MEDIUM

CVE-2019-10070 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.atlas:apache-atlas. A fix is available for org.apache.atlas:apache-atlas — see the affected versions and patch details below.

Stored XSS in Apache Atlas

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.94%1.39%1.85%2.30%1.4%1.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.atlas:apache-atlas☕org.apache.atlas:apache-atlas

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Atlas versions 0.8.3 and 1.1.0 were found vulnerable to Stored Cross-Site Scripting in the search functionality

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.atlas:apache-atlasall versions0.8.4org.apache.atlas:apache-atlas:0.8.4
☕Mavenorg.apache.atlas:apache-atlas≥ 1.0.0&&< 1.2.01.2.0org.apache.atlas:apache-atlas:1.2.0

Affected Products

1 product · 2 configurations
Application
atlasapache
2 versions
0.8.31.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.atlas:apache-atlas, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.atlas:apache-atlas to 0.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-10070 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Apache Atlas versions 0.8.3 and 1.1.0 were found vulnerable to Stored Cross-Site Scripting in the search functionality
O3 Security · Impact-Aware SCA

Is CVE-2019-10070 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2019-10070: apache-atlas XSS — Fixed in 0.8.4