NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-8006 — activemq-web-console

MEDIUMFix: apache/activemq@2373aa1

CVE-2018-8006 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.activemq:activemq-web-console. EPSS puts its 30-day exploitation probability at 55.4% (99th percentile). A fix is available for org.apache.activemq:activemq-web-console — see the affected versions and patch details below.

Apache ActiveMQ web console vulnerable to Cross-site Scripting

Also known asGHSA-hvwm-2624-rp9x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
55.4%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
48.1%61.1%74.2%87.3%79.9%55.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.activemq:activemq-web-console

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the queue.jsp page of Apache ActiveMQ versions 5.0.0 to 5.15.5. The root cause of this issue is improper data filtering of the QueueFilter parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-web-console≥ 5.0.0&&< 5.15.65.15.6org.apache.activemq:activemq-web-console:5.15.6

Affected Products

1 product · 1 configurations
Application
activemqapache
≥ 5.0.0 && ≤ 5.15.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-web-console, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-web-console to 5.15.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-8006 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2018-8006

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-8006 -u https://target
Template
Apache ActiveMQ <=5.15.5 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary script code in the context of the victim's browser, potentially leading to session hijacking, defacement, or theft of sensitive information.
Remediation
Upgrade Apache ActiveMQ to a version higher than 5.15.5 or apply the necessary patches provided by the vendor.

Template by ProjectDiscovery nuclei-templates (pdteam), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the queue.jsp page of Apache ActiveMQ versions 5.0.0 to 5.15.5. The root cause of this issue is improper data filtering of the QueueFilter parameter.
O3 Security · Impact-Aware SCA

Is CVE-2018-8006 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-8006: activemq-web XSS — Fixed in 5.15.6