NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2018-7490 — uwsgi

HIGHFix: unbit/uwsgi@0a480f4

CVE-2018-7490 is a high-severity (CVSS 7.5) Path Traversal vulnerability in uwsgi. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for uwsgi — see the affected versions and patch details below.

uWSGI Directory Traversal vulnerability

Also known asGHSA-h2vm-c85r-5vh5PYSEC-2018-78
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
69.4%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
62.3%74.8%87.4%100.0%93.3%69.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍uwsgi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIuwsgiall versions2.0.17pip install --upgrade 'uwsgi==2.0.17'

Affected Products

2 products · 3 configurations
OS
debian linuxdebian
2 versions
8.09.0
Application
uwsgiunbit
< 2.0.17
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44223webappsphp✓ Verified

uWSGI < 2.0.17 - Directory Traversal

by Marios Nicolaides · Mar 2, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for uwsgi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update uwsgi to 2.0.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7490 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2018-7490

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-7490 -u https://target
Template
uWSGI PHP Plugin Local File Inclusion
Severity
high
Impact
An attacker can read sensitive files on the server, potentially leading to unauthorized access or information disclosure.
Remediation
Update to the latest version of uWSGI PHP Plugin or apply the necessary patches to fix the local file inclusion vulnerability.

Template by ProjectDiscovery nuclei-templates (madrobot), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

uWSGI before 2.0.17 mishandles a DOCUMENT_ROOT check during use of the --php-docroot option, allowing directory traversal.
O3 Security · Impact-Aware SCA

Is CVE-2018-7490 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-7490: uwsgi Path Traversal — Fixed in 2.0.17