CVE-2018-7274 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in yab/quarx. A fix is available for yab/quarx — see the affected versions and patch details below.
Yab Quarx persistent cross-site scripting vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
yab/quarxReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Yab Quarx through 2.4.3 is prone to multiple persistent cross-site scripting vulnerabilities: Blog (Title), FAQ (Question), Pages (Title), Widgets (Name), and Menus (Name).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | yab/quarx | all versions | 2.4.5composer require yab/quarx:^2.4.5 |
Affected Products
quarx cmsquarx_cms_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yab/quarx, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update yab/quarx to 2.4.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7274 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2018-7274 in your dependencies?
Find it across Packagist, including transitive dependencies.