NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2018-5361 — wpglobus

HIGH

CVE-2018-5361 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in wpglobus/wpglobus. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for wpglobus/wpglobus — see the affected versions and patch details below.

WPGlobus plugin Stored XSS & CSRF security vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.51%1.02%1.52%0.5%1.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘wpglobus/wpglobus

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The WPGlobus plugin 1.9.6 for WordPress has CSRF via wp-admin/options.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwpglobus/wpglobusall versions1.9.7composer require wpglobus/wpglobus:^1.9.7

Affected Products

1 product · 1 configurations
Application
wpglobuswpglobus
1 version
1.9.6
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wpglobus/wpglobus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wpglobus/wpglobus to 1.9.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-5361 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The WPGlobus plugin 1.9.6 for WordPress has CSRF via `wp-admin/options.php`.
O3 Security · Impact-Aware SCA

Is CVE-2018-5361 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-5361: wpglobus CSRF — Fixed in 1.9.7