NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-5233 — grav

MEDIUM

CVE-2018-5233 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in getgrav/grav. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for getgrav/grav — see the affected versions and patch details below.

Grav CMS Cross-site scripting (XSS) vulnerability

Also known asGHSA-977g-93f5-rqjx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%7.83%15.7%23.5%18.8%3.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘getgrav/grav

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in system/src/Grav/Common/Twig/Twig.php in Grav CMS before 1.3.0 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to admin/tools.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgetgrav/gravall versions1.3.0composer require getgrav/grav:^1.3.0

Affected Products

1 product · 1 configurations
Application
grav cmsgetgrav
< 1.3.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getgrav/grav, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update getgrav/grav to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-5233 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2018-5233

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2018-5233 -u https://target
Template
Grav CMS <1.3.0 - Cross-Site Scripting
Severity
medium
Impact
Attackers can execute arbitrary JavaScript in victims' browsers, potentially stealing session cookies, administrative credentials, or performing actions on behalf of authenticated users.
Remediation
Upgrade Grav CMS to version 1.3.0 or later, which includes proper input sanitization to mitigate the XSS vulnerability.

Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in system/src/Grav/Common/Twig/Twig.php in Grav CMS before 1.3.0 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to admin/tools.
O3 Security · Impact-Aware SCA

Is CVE-2018-5233 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-5233: grav XSS — Fixed in 1.3.0